arpReach version 1.4 is available

arpReach version 1.4 releasedIt’s been a long time coming but we are proud to announce that arpReach 1.4 is now available.

A personal note from Kevin

The first thing I want to do is publicly thank the arpR team for all of the hard work and effort you have put in to make this release a reality.  In no particular order, John, Sarah, Paul, Jill, Frank, Jeff & Jess – thank you!

Next I’d like to thank the beta testing team and our trusted service partners for all of the time you have given in identifying bugs and helping with some of the improvements.  I’m so glad all you folks found (so far) were minor issues and one glaring spelling gaff (I won’t fiddle again at the last minute 😉 ).  None of which have held up this release. 

And finally I want to thank all of arpReach’s loyal and long standing customers.  Myself and the team have been touched by the warmth and encouragement in the messages you have sent and posted since we took control of arpReach.  I know how much you’ve wanted (and waited for) an update to (y)our favourite email marketing and contact management tool.  Now that we’ve got this release under our belt we can begin to implement further improvements and regular updates.

We have lots of things planned which, moving forward, we know will help you with your email marketing.  Watch out for updates and emails about those plans and do get involved.

Good luck to you all and thanks once again,

Kevin

What’s new in arpReach 1.4?

 arpreach gold and standard boxesPHP requirement

The minimum PHP version requirement is now 5.5.x with a recommendation you use PHP 5.6.x

This is a major change as the earlier version had a requirement of 5.3.  This was causing issues with some new installations as virtually all hosting companies no longer provide servers with 5.3.  Given also that support for PHP 5.3 has ceased along with 5.4, we’ve bought arpReach upto 5.5.  This makes it much simpler to install, removes the known error messages and makes your servers safer.

New Features

The main new feature in the arpReach Gold 1.4 release is …  We’ve introduced the API, v1

The introduction of an API was the most requested feature based on the results of the questionnaire we ran just after we took over.  Introducing the v1 API into Gold benefits everyone.  Now arpReach can be integrated into all of the other tools and services that businesses use on a daily basis.

There are some awesome services and sites out there for lead capture and ecommerce that already integrate with monthly autoresponder services using API’s.  Now that arpReach has one, it opens the door for developers to capture all of that useful business data in arpReach where we can use it how we want.  We have already been in touch with quite a few companies and are looking forward to seeing arpReach options appear 🙂

How you can get involved:

First and foremost, get the word out.  Tell the owners of the tools and services that you use that arpReach has an API and ask them to integrate with us.

Next, we would like the arpReach community to pool together and grow together.  We will be releasing our ideas and plans for a ‘community hub’ in the very near future but to start the ball rolling we are asking all of the developers who are arpReach users to let us know what you are integrating our API with.  We would love it if you would share your work with other arpReach users and the ‘community hub’ will be a central resource where everyone can find what they need while giving you some exposure.

What are the API v1 functions in 1.4

  • Add a Contact
  • Edit a Contact
  • Delete a Contact
  • Add a Category
  • Add a Contact to a Category
  • Get a Contact record
  • Move a contact from one list to another
  • Unsubscribe a contact from one or more lists
  • Suppress Sending to a Contact

We are looking forward to your feedback so we can improve the API

Bug Fixes

Yes!  We’ve fix lots of the bugs that had been reported.  There are too many to list here but you’ll be able to see the list in the change-log.

How do you upgrade to arpReach 1.4?

We’ve provided instructions for existing licensed users of arpReach Gold or Standard here: How do I upgrade to arpReach 1.4

 Where can I order arpReach 1.4?

You can order arpReach 1.4 here

How do I upgrade from arpReach Standard to arpReach Gold?

You can upgrade arpreach Standard to Gold here

Can I upgrade from ARP3 to arpReach Gold?

Yes you can, use this link to upgrade ARP3 to arpReach Gold

How much of a difference will the new version of arpReach make to you?  How happy are you that there is finally a new version?

Share the news and your thoughts.

 

Share this with others ...Share on Google+Tweet about this on TwitterShare on LinkedInShare on FacebookShare on Reddit

4 thoughts on “arpReach version 1.4 is available”

  1. Yes! Thank you all very much 🙂

    I’m working on a new membership site and it will be nice to integrate the API to automatically switch members between lists when they upgrade or downgrade.

    TIP: The API can be used to trigger actions 😉

    Reply

Leave a Reply to Justin Cancel reply