Upgrading to version 1.5

how to upgrade to 1.5Upgrading to the latest version release of arpReach is a simple process if you follow the basic process outlined below. While a little technical knowledge will help anyone can perform an upgrade.

If you are uncertain, worried or just don’t have the time, we recommend you seek the help of a third party professional. Licensed users are welcome to contact the support desk who will provide you with a list of partners we work with on a regular basis who can perform your upgrade for a reasonable fee.

Important Notes:

The 1.5 upgrade cannot be used to upgrade versions below 1.2.002 or pre-release (beta) versions.

! Make sure your server meets the minimum requirements !

– PHP 5.5.x
– register_globals OFF
– safe_mode OFF
– max_execution_time = 0
– cgi.fix_pathinfo = 1 (for CGI/FastCGI)
– mysql extension
– cURL extension
– GD extension
– JSON extension
– Open SSL extension

The 1.5 release introduces a new module to help you verify new email addresses are valid and check your existing lists.  While the module is free for arpReach users it does require that you sign up for the arpVerify list verification service.  The cost of using arpVerify will vary according to the size of your list.

arpReach will work without you enabling arpVerify.

The Upgrade Process:

1. Login to hub.arpreach.net and click on the Download Latest Software link

download software

2. In the To upgrade existing installations of arpReach 1.2.003 to 1.5.00x section click on the download link

download upgrade

3. Read and accept the usage terms agreement.

agree eula terms

4. The system will build your download and then present an OK button. building licensed download

6. Click OK to begin your download and save the zip file to a location you can access on your computerclick ok to download

We can’t stress this next part strongly enough. Back up, Back up, Back up.

7. BACK UP your arpReach database and then back up all of the files and folders of your existing arpReach installation. Keep these in a safe location in case you need them. Your hosting company will be able to provide you with the details you need, these vary from server to server and as a result we are unable to provide help with this element.

8. Ensure your version of arpReach is 1.2.002 or above. The version number is shown at the bottom left of every screen in arpReach.

9. Unzip the arpreach_upgrade.zip file you downloaded and saved to your computer. This file contains the file arpreach_upgrade_files.zip, a change log txt file and a txt file called README-FIRST. Read the read me file for version specific upgrade instructions and the changelog so you know what’s been fixed.

10. Unzip the file arpreach_upgrade_files.zip you downloaded and saved to your computer.

11. Using your FTP software, upload the contents of the arpreach_upgrade_files zip file in * binary mode * to the server directory containing your arpReach installation.

12. When asked to replace existing files, choose yes. Do not choose any option that would delete existing files or directories apart from those being uploaded.

13. If you are signed in to arpReach, sign out then sign in again. This step is important as it updates the database tables.

14. You now see a message telling you ‘A new activation code is needed’.

activation code needed

15. Log in to http://hub.arpreach.net – create a new activation code for your registered domain

domain activation code

16. Copy the new activation code and paste it in to the ‘Activation Code’ box in your arpReach site. Add your license number and password in the appropriate boxes. Read the terms and conditions, click the box if you agree.

activate license

17. Click the ‘Activate Now’ button

Congratulations your arpReach installation has been updated.

Things to be aware of

Where this release fixes numerous issues including the sending of BCC notifications and attachments, old autoresponders will start sending them. Thanks to Sheri Gormley for pointing this out. Do check your autoresponders to make sure the right people are getting BCC’d and your attachment content to ensure it is still valid.

If you have customized your language files please be aware that we have added new files for the arpVerify integration and you will need to add these and change them as appropriate within your customization  (Thanks Tom for pointing this out).

If you need help please contact the arpReach support team and raise a ticket

Share this with others ...Share on Google+Tweet about this on TwitterShare on LinkedInShare on FacebookShare on Reddit

1 thought on “Upgrading to version 1.5”

Leave a Reply to Tom Cancel reply